The ICMP probe does not collect metrics from the devices
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The ICMP probe does not collect metrics from the devices

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Article ID: 253764

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Some of our devices were collecting ICMP metrics, but suddenly they stopped doing it.

In OC, under Inventory, the devices still appears as "Monitored By" icmp probe.

However when we try to Configure the probe in AC, the list of resources (monitored devices) is not listed, and I can only see the list is still there when we Raw Configure the probe.

 

Environment

  • Release: 20.4

Cause

  • Corrupted icmp.cfg file can cause this behavior. This may happen if the .cfg doesn't contain all the sections.

Resolution

The problem might be caused by a corrupted icmp.cfg. For instance in the next image the icmp.cfg only has 2 sections, and not all the keys expected under the setup section:

A normal icmp.cfg include 4 sections: setup, resources, qos_code and startup section.

Adding the missing sections and keys to the corrupted icmp.cfg and cold starting the probe can resolve the problem.

If this doesn't work, it might be necessary to backup the corrupted icmp.cfg, redeploy the probe, and then manually add the resources section to the new deployed .cfg

Additional Information