TIRM030E "CSU-ERROR: (rc = 2) ... CreateFile(CM Mail Slot)"
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TIRM030E "CSU-ERROR: (rc = 2) ... CreateFile(CM Mail Slot)"

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Article ID: 253727

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Updated On:

Products

Gen Gen - Run Time Distributed Gen - Workstation Toolset Gen - Host Encyclopedia

Issue/Introduction

Gen 8.6 client/server application where the GUI client is using Client Manager to connect to the server.
The Gen 8.6 generated client application and required runtime files have been deployed to users' machines
For a couple of users this error has occurred intermittently:
TIRM030E: Application failed - Updates have been backed out
CSU-ERROR: (rc = 2) executing CreateFile(CM Mail Slot) in flowSetup(CM)().

Environment

Release : 8.6

Cause

The "CreateFile(CM Mail Slot) in flowSetup(CM)" indicates that the Gen GUI client is trying to use a Client Manager (CM) to connect to the server, but it appears that it cannot connect to the CM. This problem could occur if the CM is not running/has stopped running on the client machine.

Resolution

To assist with the root cause analysis perform these steps to collect diagnostic files during future Gen client application use:

a. In the commcfg.ini file being used by the client application add line "CMIDEBUG ON" to cause client trace files ("trace-<procname>-<procid>.out") to be created in directory "%USERPROFILE%\AppData\Local\CA\Gen 8.6\logs\client".
NOTE: See notes at bottom of the commcfg.ini file on how that file is found by the Gen client application (installed copy is in Gen 8.6 install directory "%Gen86%\Gen")

b. In the CM menu option File/Setup enable "Logging Level = Tracing" and restart the CM. That will result in a trace level file IEFCMN.log being created in directory "%USERPROFILE%\AppData\Local\CA\Gen 8.6\logs\cm".

c. The 2 CM configuration files iefcmn.ini and IEFCMN.SRV from directory "%USERPROFILE%\AppData\Local\CA\Gen 8.6\cfg\cm".

Additional Information

The problem did not recur so diagnostic files could not be collected for root cause analysis. If similar problem is observed please collect requested diagnostic files and create a support case via the Broadcom Support Portal for the Gen Support team to provide assistance: https://support.broadcom.com/

Gen™ 8.6 > Distributed Processing > Working With Distributed Processing > Overriding Communications Support at Execution Time