"AHD05543: Your changes to Registration parameters match an existing Configuration Item" when updating a CI
search cancel

"AHD05543: Your changes to Registration parameters match an existing Configuration Item" when updating a CI

book

Article ID: 25367

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Updating a given CI on its Host name or DNS name fields of a Configuration Item (CI) gives the error

 "AHD05543: Your changes to Registration parameters match an existing Configuration Item".

Environment

Release: 17.3 or higher
Component:  CA Service Desk Manager

Cause

This could be related with the asset registration into the CORA.

Resolution

The pdm_reg_assets command can be used, with different options, to solve this kind of problem (type pdm_reg_assets -h to get an explanation for all options):

Plain Asset Registration - pdm_reg_assets 

Asset Registration with duplicate Fix-up - pdm_reg_assets -f 

Asset Registration cleanup (deregistration) - pdm_reg_assets -U 

Run the following 3 commands so that the problem related to asset registration can be solved:

back up the mdb then  

  1. pdm_reg_assets
  2. pdm_reg_assets -f
  3. pdm_reg_assets -U

Note: These commands should be run in the order listed.

No restart is necessary for these changes to take effect.