CoraCleanup does not work with r17.3 RU17 or RU18
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CoraCleanup does not work with r17.3 RU17 or RU18

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Article ID: 253658

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

All CORA entries will be deleted from the DB, but no new CORA registrations happen.
That means, all CIs are lost from the ca_asset* tables.

Example:
Before CoraCleanup the tables ca_asset and ca_asset_source contain ### rows.

After CoraCleanup both tables are empty!


The message "reregisterAll The result set is closed" should not be displayed in
command line results.

C:\SDM17_3_RU17/18_CORACLEANUP>"c:\Program Files (x86)\CA\Service Desk Manager\bin\coracleanup.cmd"
/DATABASE mdb /SERVER testserver /SCOPE all /METHOD reinit /TYPE 2 /USERNAME sa /PASSWORD XXX /LOG full

Assets Read = 0, Registration Successful = 0, Registration Failed = 0reregisterAll The result set is closed.
Assets Read = 0, Registration Successful = 0, Registration Failed = 0
All Done.

 

Environment

Release: 17.3 RU17 - 18

Component: SDM - Configuration Management (CMDB/Visualizer/Grloader)

Cause

Known defect with release 17.3 RU17 and or RU18.

Resolution

The issue was resolved with the release of  17.3 RU 19. Environment upgrade to 17.3 RU19 or the latest RU patch is recommended.