Cloud email is being blocked with a sender rewrite rule in place with Exchange Online
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Cloud email is being blocked with a sender rewrite rule in place with Exchange Online

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Article ID: 253654

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Updated On:

Products

Data Loss Prevention Cloud Service for Email

Issue/Introduction

Email from domains that are being rewritten to a new domain with a sender rewrite rule are blocked.

  • It may appear to be inconsistent with which users are seeing the issue with email being blocked until the character limit is noted.

Environment

DLP Release : 15.x-16.x

Cloud Service for Email with either Microsoft 365 or Exchange Online

Cause

SRS rewriting causes the username part of an email address to increase in length. The email address has a limit of 64 characters. If the email address involves the SRS rewriting and exceeds 64 characters, the rewritten SRS address will take the form of "bounces".

The [email protected] exceeds the 64-character limit.

In this case, only users with longer names were being bounced, and some users with shorter names were able to send the email with success

Resolution

Shorten either the domain name or user name to be under the 64-character limit.

Additional Information

Sender Rewriting Scheme (SRS) in Microsoft 365