search cancel

Possible SMP/E errors during install of TPX 5.4.1 level set ptf

book

Article ID: 253650

calendar_today

Updated On:

Products

TPX - Session Management

Issue/Introduction

In order to install fix LU06465 (CONTINUOUS DELIVERY LEVEL SET 5.4.01), SMP/E requires to install also its prerequisite fix RO88547, either previously or in the same APPLY command.

Depending on how TPX 5.4 was installed onsite, SMP/E APPLY of the prerequisite fix RO88547 may fail with the following error: 

GIM54701E ** ALLOCATION FAILED FOR CB0VPDEU - IKJ56228I DATA SET CAI.TPX.R540.CB0VPDEU NOT IN CATALOG OR CATALOG CAN NOT 
              BE ACCESSED.                                                                                                
 GIM28303E ** ALLOCATION FAILED FOR CB0VPDEU, WHICH IS REQUIRED IN ORDER TO PROCESS SYSMOD RO88547.                       
 GIM22601I    APPLY PROCESSING FAILED FOR SYSMOD RO88547.

Environment

Release : 5.4

Cause

This will happen if, during the install of release 5.4, the site did NOT install FMID CB0V548, which installs the TPX panels translated to German language (TDExxxxx) and is the result of a concatenation of events.

When TPX 5.4 GA release was delivered, panel TGE5003 was NOT present in FMID CB0V548 and its target library CB0VPDEU, which install the German language panels.

PTF RO84919 was published to add the missing panel to the CB0VPDEU library. This fix was mistakenly assigned to FMID CB0V540 (which is the base TPX FMID).

When this mistake was detected, fix RO88547 was published to delete the panel from the  CB0VPDEU library under FMID CB0V540 and subsequent fix RO88554 was published to (this time correctly) add the panel to library CB0VPDEU under the correct FMID CB0V548

Later on, TPX started to deliver 'level set PTFs', which are intended to define maintenance levels which are easily identifiable by a level stamp like 'TPX 5.4.01' which is displayed at runtime. In order to enforce the concept, the fix that introduces the level set defines all previous published fixes as SMP/E prereqs.

For this reason, fix LU06465 (which installs TPX level set 5.4.1) names RO84919 and RO88547 as prerequisites and SMP/E will require to have RO88547 applied in order to install LU06465. Note that fix RO84919 is not needed because RO88547  supercedes  RO84919.

This leads to the situation described in this document. The customer needs to apply LU06465 but, to do that, SMP/E requires to apply also fix RO88547, which in turn requires a CB0VPDEU library containing member TDE5003 just to delete it.

 

 

 

Resolution

The easiest way to get out of this situation would be:

  1. Create a dummy library with the same DCB attributes of CB0VPENU library (the english panels library)
  2. Copy member TEN1003 from CB0VPENU library into member TGE1003 into that dummy  library
  3. Apply fix RO88547 adding the following DD to the SMP/E JCL:
    //CB0VPDEU DD DISP=SHR,DSN=the.dummy.library

During APPLY processing, ddname  CB0VPDEU specified in the JCL will override the DSN which was stored in the SMP/E DDEF entry for CB0VPDEU library during the initial TPX install.

This way, SMP/E will not try to dynamically allocate the CB0VPDEU library and will be able to delete panel TGE1003 from the dummy library. This way, fix RO88547 will be successfully applied and SMP/E will allow to install LU06465