search cancel

Any concern compiling a Smart/Restart program with v20.0 and running it on v12.1.2?

book

Article ID: 253645

calendar_today

Updated On:

Products

Smart Restart

Issue/Introduction

Smart/Restart upgraded to v20.0 in development but production is still executing v12.1.2.
Will there be any compatibility issues with compiling a Smart/Restart program with v20.0
and executing it under v12.1.2?

Environment

Release : 20.0

Resolution

Expectations are that the compiled Smart/RESTART programs under v20.0 will
execute successfully under the Smart/RESTART v12.1.2 code level.

There are no changes in the Smart/RESTART APIs that would cause a
program precompiled on v20 to fail if running on a system with v12.1.2.