DISK product - ISPF error "Error obtaining the device name" - for ARCHIVED dataset
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DISK product - ISPF error "Error obtaining the device name" - for ARCHIVED dataset

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Article ID: 253516

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Updated On:

Products

Disk Backup and Restore - MVS

Issue/Introduction

After an IPL, this error can appear when recalling a dataset with the DISK product.

SYSA T - Data Sets Matching ABCDE0.*                              Volume error 
Command ===>                                                  Scroll ===> CSR  
                                                                               
Command - Enter "/" to select action                  Message           Volume 
-------------------------------------------------------------------------------
        ABCDE0.data set name 1                                                  ARCIVE 
         ABCDE0data set name 2                                                  VVVVV 
         ABCDE0data set name 3                                                  ZZZZZ 
         ABCDE0.data set name 4                                                XXXXX 
         ABCDE0.data set name 5                                               ARCIVE 
         ABCDE0.data set name 6                                              ARCIVE 
         
ssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssss
 Error obtaining the device name for the data set or volume entered, for one  
 of the following reasons: volume not mounted, device table not found, device 
 table empty, or the UCB for the volume could not be found.                   
ssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssss

Environment

DISK R14.0 
ISPF

Cause

In this instance the DISK HOOKS had not been installed at IPL time.

The message is issued from ISPF and not the DISK product as it is not active at the time of the error.

 

Resolution

Issue commands:
/S DMSAR,DMSAR=STATUS        - to determine the status of the DISK hooks.

/S DMSAR,DMSAR=INSTALL   :      or
/S DMSAR,DMSAR=REFRESH     - to reinstall the DISK hooks.



Additional Information

The DISK product cannot identify the problem as the HOOKs are not installed.  

From the Documentation:
The Disk catalog management hook and DFHSM SVC hook are removed each time you IPL. Therefore, you must use the previous procedure to reinstall the hooks when you IPL. Consider installing the command in the automatic start-up procedures.

For more information refer Install the Auto Restore function