Desktop PAM client install issue (java vm error 2)
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Desktop PAM client install issue (java vm error 2)

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Article ID: 253484

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

The installation starts normally but seems to simply disappear around 80% complete

We have a group of several users who are unable to install the PAM desktop client. Below is the users' description of what happens when they try to install.

These are the diagnostic steps I've taken:

1) I asked them to download the 4.0.1 from one of our appliances rather then the 3.3.0 client installer they were using.

2) I had them fully delete any client and associated files before reinstalling 4.0.1.

3) I had them confirm they are using a recent version of Java (1.8.0-192-b12).

4) I had the user try installing both on and off our corporate VPN.

None of these actions seemed to make a difference.

 

Description from user #1:

The program attempts to open then closes without any error, completion, notification or warning.

Description from user #2 (note the reference to version 3.3.0 which we had them update):

I am trying to install the PAM client on my laptop and not having success.  When I double click on the installation exe it flashes and doesn't do anything.  I have tried to install it with and without admin rights and I see the same behavior.  I have run the following command that did allow me to install the application, but then nothing happens when I try to open it.  capamclientinstall_v330.exe LAX_VM "C:\Program Files (x86)\Java\jre6\bin\java.exe" pointing the LAX_VM to my jre.  I have tried pointing to my JRE and my JDK in programs(86) and programs folder.  My current state is the PAM client looks like it is installed, although it is missing files according to the few people on my team that could get this to install.  The uninstaller is now doing the same thing.  It flashes when I try to remove the application and does nothing.

Environment

Release : Reported for 4.0, but all PAM (client) releases are affected.

Cause

The desktops have environment variable _JAVA_OPTIONS set with an Xmx (maximum heap size) setting that is incompatible with a 32-bit Java application such as the PAM client installer, or the PAM client launcher. Example problem settings:

-Xmx2048M

-Xmx8g

On Windows desktops a 32-bit Java application typically will fail if this setting exceeds 1280M.

Resolution

The issue was resolved as DE548628 in the 4.1.2 release.

If an upgrade is not currently possible, a workaround would be to temporarily or permanently change or unset the environment variable. Most Java applications have a local properties files that allows setting of this parameter within the context of the application, rather than setting an environment variable that affects all Java applications on the system. E.g. the PAM client has a settings.properties file in its installation folder. However, the environment variable trumps this setting in the current implementation.

Additional Information

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/privileged-access-manager/4-1-4/release-information/resolved-issues-in-earlier-4-x-releases/Resolved-Issues-in-4-1-2.html