Error: Failed to re-generate pull install packages
search cancel

Error: Failed to re-generate pull install packages

book

Article ID: 253475

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

The customer is trying to make a change on his Agent Communication Profile (under Settings>All Settings>Agents/Plug-ins>Symantec Management Agent>Symantec Management Agent Communication profiles), and when he clicks on "Save changes" he gets the errors:

Failed to re-generate pull install packages. Please re-configure them from Default setting on Agent Install page.
Failed to save communication profile. Reason: The system cannot find the file specified.

The following errors were present in the NS logs:

Entry 1:

Failed to generate packages for pull install:

The system cannot find the file specified
   [Altiris.NS.Exceptions.AeXException @ Altiris.NS.StandardItems]
   at Altiris.NS.StandardItems.AgentManagement.CEMPackageRegistrator.BuildSitePackage(PackageMode mode, String siteIdentifier, IEnumerable`1 gateways, IEnumerable`1 resourceTargets, IEnumerable`1 organizationalGroups, String additionalInstallParams, DateTime requestedPackageExpiry, AgentPackageParameters packageParams, DateTime& packageExpiry, String& installXML)
   at Altiris.NS.StandardItems.AgentManagement.AgentPackages.AgentPackagesUtils.GenerateAgentPackages(String& sInstallXMLHTTP, String& sInstallXMLHTTPs, String& sPackageLoacation, Boolean bSkipDistributionPointsUpdate, GenerationType generationMode)

Exception logged from: 
   at Altiris.NS.StandardItems.AgentManagement.AgentPackages.AgentPackagesUtils.GenerateAgentPackages(String&, String&, String&, Boolean, Altiris.NS.StandardItems.AgentManagement.AgentPackages.AgentPackagesUtils+GenerationType)
   at Altiris.NS.UI.Admin.Configuration.ConnectionProfiles.cfgConnectionProfile.GeneratePackages()
   at Altiris.NS.UI.Admin.Configuration.ConnectionProfiles.cfgConnectionProfile.SaveSettings()
   at Altiris.NS.UI.Admin.Configuration.ConnectionProfiles.cfgConnectionProfile.OnClickOK()
   at Altiris.NS.UI.Admin.Configuration.ConnectionProfiles.cfgConnectionProfile.RaisePostBackEvent(String)
   at System.Web.UI.Page.ProcessRequestMain(Boolean, Boolean)
   at System.Web.UI.Page.ProcessRequest(Boolean, Boolean)
   at System.Web.UI.Page.ProcessRequest()
   at System.Web.UI.Page.ProcessRequest(System.Web.HttpContext)
   at Altiris.NS.UI.Controls.PageCachePage.ProcessRequest(System.Web.HttpContext)
   at Altiris.NS.UI.AltirisPage.ProcessRequest(System.Web.HttpContext)
   at System.Web.HttpApplication+CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStepImpl(System.Web.HttpApplication+IExecutionStep)
   at System.Web.HttpApplication.ExecuteStep(System.Web.HttpApplication+IExecutionStep, Boolean&)
   at System.Web.HttpApplication+PipelineStepManager.ResumeSteps(Exception)
   at System.Web.HttpApplication.BeginProcessRequestNotification(System.Web.HttpContext, AsyncCallback)
   at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(System.Web.Hosting.IIS7WorkerRequest, System.Web.HttpContext)
   at System.Web.Hosting.PipelineRuntime.ProcessRequestNotificationHelper(IntPtr, IntPtr, IntPtr, Int32)
   at System.Web.Hosting.PipelineRuntime.ProcessRequestNotification(IntPtr, IntPtr, IntPtr, Int32)

HTTP [POST]: https://altrns.domain.local/Altiris/NS/Admin/Configuration/ConnectionProfiles/cfgConnectionProfile.aspx?Guid=53badd6a-a513-4526-9c84-4fc7c8b4d86a
 ip: [10.190.4.99]; languages: [en-US,en;q=0.9]; content-length: [33420];
 timings: [[R] 00:00:01.1350644(W: 00:00:00)];
 response: [200 OK]; x-smp-nsversion: [8.6.4286.0];

-----------------------------------------------------------------------------------------------------
Date: 11/2/2022 9:40:59 AM, Tick Count: 8998250 (02:29:58.2500000), Size: 3.34 KB
Process: w3wp (4736), Thread ID: 649, Module: Altiris.NS.StandardItems.dll
Priority: 1, Source: Altiris.NS.StandardItems.AgentManagement.AgentPackages.AgentPackagesUtils.GenerateAgentPackages

Entry 2:

Unable to load the profile settings

The system cannot find the file specified
   [Altiris.NS.Exceptions.AeXException @ Altiris.NS.StandardItems]
   at Altiris.NS.StandardItems.AgentManagement.CEMPackageRegistrator.BuildSitePackage(PackageMode mode, String siteIdentifier, IEnumerable`1 gateways, IEnumerable`1 resourceTargets, IEnumerable`1 organizationalGroups, String additionalInstallParams, DateTime requestedPackageExpiry, AgentPackageParameters packageParams, DateTime& packageExpiry, String& installXML)
   at Altiris.NS.StandardItems.AgentManagement.AgentPackages.AgentPackagesUtils.GenerateAgentPackages(String& sInstallXMLHTTP, String& sInstallXMLHTTPs, String& sPackageLoacation, Boolean bSkipDistributionPointsUpdate, GenerationType generationMode)
   at Altiris.NS.UI.Admin.Configuration.ConnectionProfiles.cfgConnectionProfile.GeneratePackages()

Exception logged from: 
   at Altiris.NS.UI.Admin.Configuration.ConnectionProfiles.cfgConnectionProfile.GeneratePackages()
   at Altiris.NS.UI.Admin.Configuration.ConnectionProfiles.cfgConnectionProfile.SaveSettings()
   at Altiris.NS.UI.Admin.Configuration.ConnectionProfiles.cfgConnectionProfile.OnClickOK()
   at Altiris.NS.UI.Admin.Configuration.ConnectionProfiles.cfgConnectionProfile.RaisePostBackEvent(String)
   at System.Web.UI.Page.ProcessRequestMain(Boolean, Boolean)
   at System.Web.UI.Page.ProcessRequest(Boolean, Boolean)
   at System.Web.UI.Page.ProcessRequest()
   at System.Web.UI.Page.ProcessRequest(System.Web.HttpContext)
   at Altiris.NS.UI.Controls.PageCachePage.ProcessRequest(System.Web.HttpContext)
   at Altiris.NS.UI.AltirisPage.ProcessRequest(System.Web.HttpContext)
   at System.Web.HttpApplication+CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStepImpl(System.Web.HttpApplication+IExecutionStep)
   at System.Web.HttpApplication.ExecuteStep(System.Web.HttpApplication+IExecutionStep, Boolean&)
   at System.Web.HttpApplication+PipelineStepManager.ResumeSteps(Exception)
   at System.Web.HttpApplication.BeginProcessRequestNotification(System.Web.HttpContext, AsyncCallback)
   at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(System.Web.Hosting.IIS7WorkerRequest, System.Web.HttpContext)
   at System.Web.Hosting.PipelineRuntime.ProcessRequestNotificationHelper(IntPtr, IntPtr, IntPtr, Int32)
   at System.Web.Hosting.PipelineRuntime.ProcessRequestNotification(IntPtr, IntPtr, IntPtr, Int32)

HTTP [POST]: https://altrns.domain.local/Altiris/NS/Admin/Configuration/ConnectionProfiles/cfgConnectionProfile.aspx?Guid=53badd6a-a513-4526-9c84-4fc7c8b4d86a
 ip: [10.190.4.99]; languages: [en-US,en;q=0.9]; content-length: [33420];
 timings: [[R] 00:00:01.1360653(W: 00:00:00)];
 response: [200 OK]; x-smp-nsversion: [8.6.4286.0];

-----------------------------------------------------------------------------------------------------
Date: 11/2/2022 9:40:59 AM, Tick Count: 8998250 (02:29:58.2500000), Size: 3.19 KB
Process: w3wp (4736), Thread ID: 649, Module: Altiris.Web.NS.dll
Priority: 1, Source: Altiris.NS.UI.Admin.Configuration.ConnectionProfiles.cfgConnectionProfile.GeneratePackages

Environment

ITMS 8.5 RU4, 8.6

Cause

In this particular situation, the customer was missing the following files under ...\Program Files\Altiris\Notification Server\Bin\Tools:

SMAPackager.exe
SMATool.exe
SMAUtil.dll

Resolution

From a working server with the same version, copy and place the following files under ...\Program Files\Altiris\Notification Server\Bin\Tools:

SMAPackager.exe
SMATool.exe
SMAUtil.dll

After that, try again to save the Agent Communication Profile.