search cancel

Unable to log in to Operator Console after CU5 update

book

Article ID: 253447

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I have deployed CU5 and Operator Console does not successfully complete a login.

I am able to enter the user and password on the initial login screen and then get a page refresh and the slowly spinning circle progress indicator for 10 to 30 seconds or so and then the login screen repaints.

In the wasp.log I see:

Nov 02 08:23:13:597 ERROR [http-nio-80-exec-8, org.apache.catalina.core.ContainerBase.[wasp-engine].[localhost].[/operatorconsole_portlet]] log() Servlet.init() for servlet [rest] threw exception
Nov 02 08:23:13:597 ERROR [http-nio-80-exec-8, org.apache.catalina.core.ContainerBase.[wasp-engine].[localhost].[/operatorconsole_portlet]] org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'productUsageService' defined in URL [jar:file:/C:/Program%20Files%20(x86)/Nimsoft/probes/service/wasp/webapps/operatorconsole_portlet/WEB-INF/lib/operatorconsole-api-20.4.6.jar!/com/firehunter/operatorconsole/usagemetering/ProductUsageService.class]: Instantiation of bean failed; nested exception is java.lang.NoClassDefFoundError: Could not initialize class com.firehunter.operatorconsole.usagemetering.ProductUsageService

Environment

Release : 20.45

Cause

This occurs if the usage_metering probe is not present or disabled on the primary hub.

This is a defect; there is a new usage report in OC that depends on the usage_metering probe, but it is intended that this report is simply blank or unavailable if usage_metering data is not present.  It should not prevent login.

Resolution

To resolve this issue, download and deploy the ump_operatorconsole-20.4.7 webapp to any/all Operator Console robots.  It can be found at the following page: Operator Console CU5 Solution Page