search cancel

Role right for higher resolution is disabled when using more than 12 trends for time range

book

Article ID: 253431

calendar_today

Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

Another admin previously added High resolution capability to the "User" role.  We just did an upgrade to 22.2.3.  Now user resolution has been disabled.  Is there a new limit based on the number of trend dashboards I have on a dashboard?  

Error in charts "Role right for higher resolution is disabled when using more then 12 trends for a time range."

If I make a new view for the same group and time frame there is no error. 

Errors:

WARN  | Model-Invoker-38         | 2022-11-02 12:21:34,887 | com.ca.im.portal.plugins.rib.utils.RIBItemBasedQueryUtils        
      | Unexpected error occurred while processing isSDWanBasedRIBQuery: java.lang.NumberFormatException: For input string: "{Model.ChartMaxNumber}"
WARN  | Model-Invoker-30         | 2022-11-02 12:21:34,887 | com.ca.im.portal.plugins.rib.utils.RIBItemBasedQueryUtils        

INFO  | Model-Invoker-7          | 2022-11-02 12:21:34,887 | com.ca.im.portal.plugins.rib.models.RIBXYChartModel              
      | Model 0_47: viewTree.render
java.lang.NumberFormatException: For input string: "{Model.ChartMaxNumber}"
 at java.lang.NumberFormatException.forInputString(Unknown Source) ~[?:?]
 at java.lang.Integer.parseInt(Unknown Source) ~[?:?]
 at java.lang.Integer.valueOf(Unknown Source) ~[?:?]
 at com.ca.im.rib.repository.RIBQueryParser.processPhrase(RIBQueryParser.java:331) ~[rib.repository-5.21-RELEASE.jar:?]
 at com.ca.im.rib.repository.RIBQueryParser.parse(RIBQueryParser.java:235) ~[rib.repository-5.21-RELEASE.jar:?]
 at com.ca.im.rib.repository.RIBQueryParser.parseRequest(RIBQueryParser.java:112) ~[rib.repository-5.21-RELEASE.jar:?]
 at com.ca.im.rib.repository.RIBQueryParser.<init>(RIBQueryParser.java:88) ~[rib.repository-5.21-RELEASE.jar:?]
 at com.ca.im.portal.plugins.rib.models.RIBXYChartModel.dynamicTrendQuery(RIBXYChartModel.java:3720) ~[portal.console.plugins.rib-22.2.3-RELEASE-871.jar:?]
 at com.ca.im.portal.plugins.rib.models.RIBXYChartModel.issueDataQueryRequest(RIBXYChartModel.java:2090) [portal.console.plugins.rib-22.2.3-RELEASE-871.jar:?]
 at com.ca.im.portal.plugins.rib.models.RIBXYChartModel$RIBXYChartModelCallable.call(RIBXYChartModel.java:1746) [portal.console.plugins.rib-22.2.3-RELEASE-871.jar:?]
 at com.ca.im.portal.plugins.rib.models.RIBXYChartModel$RIBXYChartModelCallable.call(RIBXYChartModel.java:1663) [portal.console.plugins.rib-22.2.3-RELEASE-871.jar:?]
 at com.ca.im.portal.api.invoke.MethodInvoker$CallableWrapper.call(MethodInvoker.java:544) [portal-api.common.util-5.21-RELEASE.jar:?]
 at java.util.concurrent.FutureTask.run(Unknown Source) [?:?]
 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:?]
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:?]
 at java.lang.Thread.run(Unknown Source) [?:?]

 

 

Environment

Release : 21.2

Cause

View is using a configuration from a previous release that was not updated with the upgrade. This caused the error. 

Resolution

You need  to remove the view from the dashboard and replace it with the same view. It was using a view configuration from a previous release that was not updated with the upgrade. 

The issue is DE549555 and will be fixed in 22.2.4