dirscan probe 3.18 deployment failure - dependency not found error
search cancel

dirscan probe 3.18 deployment failure - dependency not found error

book

Article ID: 253262

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Trying to deploy dirscan v3.18 to a number of systems and dependency not found error is thrown.

Environment

  • Release: 20.4
  • distsrv v3.17, v3.18

Cause

- probe dependencies

Resolution

When deploying a probe package, in this case dirscan, the probe package may have dependencies and if those dependencies are not found for the target system, a dependency not found error will be thrown. This scenario applies to all probes that may contain 1 or more dependencies.

For the dirscan probe to deploy successfully and start without error, the probe requirements and dependencies need to be taken into consideration.

Probe Specific Software Requirements

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/monitoring/systems-and-service-response/dirscan-file-and-directory-scan/dirscan-file-and-directory-scan-release-notes.html

================================

The 3.12 version or later of the dirscan probe (for migration with threshold_migrator probe) requires the following software environment:

- UIM 8.31 or later
- Robot 7.5 or later (recommended)
- Probe Provisioning Manager (PPM) probe version 3.22 or later
- baseline_engine probe version 2.60 or later
- Java JRE version 7 or later

Supported OSes

==============

As of dirscan 3.17/3.18, when you check the UIM Probes Support Matrix,

https://techdocs.broadcom.com/content/dam/broadcom/techdocs/us/en/dita/ca-enterprise-software/it-operations-management/unified-infrastructure-management/uim203-flattened/topics/Platform_Support_Availability_203.xlsx

You will find that the following OSes are NOT supported:

- Windows 2012 (NON-R2)
- RHEL 8
- SUSE 12
- SUSE 15
- CentOS 6
- Open Suse 12
- Open Suse 13
- AIX 7.2
- IBM i (AS/400) V7R3

You may also open the probe package version in the local archive and click the dependencies Tab to see what dependencies are listed for a given OS, e.g.,

Dependencies

=============

Windows x64 systems:
- vs2017_vcredist_x64

Win32 Systems:
- vs2017_vcredist_x86

For example:

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=gfdkXNdYS1cvFjvTowKgeQ==

If the cause of the error is not clearly displayed in the deployment window, when the probe loglevel is set to 5 and logsize set to 100000, you can normally determine the underlying cause of the dependency not found error by running the deployment with the log open so you can watch it and see why its failing.

In some other cases, when the environment is configured to use 'Use remote distsrv on distribution' and the downstream distsrv is not using its local archive (meaning it will pull the package from the upstream distsrv) the downstream distsrv will check and validate that the upstream distsrv has ALL dependencies from ALL probe package Tabs present. If the remote distsrv is being used (instead of the local hub archive), and the package is present in the remote distsrv archive on the remote hub, with all probe package dependencies met/present, the error should not occur (unless the target OS is not currently supported).

Additional Information

For dependency errors on Linux systems first check the required Glibc versions for each supported OS at this url:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/20-4/installing/product-compatibility/ca-uim-compatibility-matrix.html#concept.dita_3e0b025267e987b38f84e5c201b1b6f9da447ad5_glibcsupport

The customer was provided with and deployed the latest (new) version of the Infrastructure Manager (IM) for 20.4 which is included in CU5 and that resolved the issue.

If UIM 20.4 CU5 is installed the new IM will be located in the /nimsoft/install/setup folder.

The only way to obtain it is to upgrade to CU5, which puts a new NimbusManager.exe at /nimsoft/install/setup which is also the same location that the Primary hub /uimhome page references.