Maileater not processing messages in Outlook365
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Maileater not processing messages in Outlook365

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Article ID: 253221

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Customer finds that emails in inbox are not being processed and tickets are not being created.

In maileater_nxd logs we see that the connection to the mailbox is successfully and polls are successful.

After some successful polls, we see that the maileater_nxd log no longer updates and this is the last log generated:

2024-08-08 17:29:07:904 DEBUG  [ForkJoinPool-1-worker-3] c.c.S.m.c.JavaMailIMAPClient - [ID:(<USER_NAME>),HN:(<HOST_NAME>)] -> [IMAPS|993] Connecting to IMAP host...

Environment

Service Management 17.4

Email integration (Both on Prem and Cloud)

Cause

After testing it was found out that the root cause of the situation was the variable NX_MAIL_INITIAL_TRACING.

Resolution

After we deinstall the nx variable NX_MAIL_INITIAL_TRACING maileater works as expected. 

This is only required in order to print logs from JavaMail(3rd party) to see how the connection is being made.

For some reason, the Javamail hangs because of logging the information @ customer site.