search cancel

CABI 7.9.1 SP2 silent non root installation with Spectrum

book

Article ID: 253200

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

We are trying to install CABI on Linux 7.9 to integrate with Spectrum SRM 21.2.12 but we are having the following issues for a non-root installation.

on the following TechDoc page it states for a non-root installation it requires "X Windows Server" group libraries installed.

Installing with Non-Root or Non-Administrator User (broadcom.com)

Unfortunately, the RHEL servers have a minimal build that does not have this library group for "X Windows Server" available in their repo distributions.

When they run the following command for the "X Windows System" library installation the following output is generated.

# yum install "@X Window System"     

Group X Window System does not exist.

Error: Nothing to do

 

What X Windows Server libraries are required as a minimum to support the X11 setup for RHEL for a non-root remote GUI installation to be successful?

When trying to launch the GUI installer remotely via an X Windows Client we receive the following response.

[[email protected] Installer]$ sh ./setup.sh 
Preparing to install
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...
                                                                                                  
                                                                                                  
Graphical installers are not supported by the VM. The console mode will be used instead...        
                                                                                                  
                                                                                                  
=======================================================                                           
                                                                                                  
Installer User Interface Mode Not Supported                                                       

The installer cannot run in this UI mode. To specify the interface mode, use the -i command-line option, followed by the UI mode identifier. The valid UI modes identifiers are GUI, Console, and Silent.

=======================================================

[[email protected] Installer]$

Environment

Release : 21.2.12

Resolution

The following KB article states we have to uninstall and then reinstall CABI using the GUI 

CABI message You are not the owner of CA Business Intelligence installation (broadcom.com)

And also, the following which states that the following library is required - libXtst

Therefore, we installed the library and tested the GUI remote X Windows and it worked. Then we followed these steps -

  1. Uninstalled CABI
  2. Start the CABI server installer which brought up the GUI remote X Windows

./setup.sh

3. Completed the installation

4. Tested that the CABI console was available on port 8080

5. All worked fine