Report Manager does not start after Upgrade to 22.2
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Report Manager does not start after Upgrade to 22.2

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Article ID: 253114

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

we did an upgrade from 10.4.2.2 to 22.2.3 and now the report manager does not work anymore.

catalina.out errors
Oct 24, 2022 10:42:57.999 (SRM/Startup/Container) (ReportManager) - (ERROR) -
Error occurred while logging custom configuration changes
Caused by: java.sql.SQLException: Operation not allowed for a result set of type ResultSet.TYPE_FORWARD_ONLY.
            at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:129)
            at com.aprisma.spectrum.app.repmgr.dc.db.ReportManagerInitializer.init(ReportManagerInitializer.java:102) ~[rpmgr.jar:?] 

Oct 24, 2022 10:42:58 AM (SRM/Startup/Container) (com.aprisma.spectrum.app.repmgr.web.servlet.SRMBootstrapServlet) -
(ERROR) - Error occurred while initializing SRM components

com.aprisma.spectrum.app.repmgr.exceptions.SRMException: Error occurred while logging custom configuration changes
            at com.aprisma.spectrum.app.repmgr.dc.db.ReportManagerInitializer.logConfigurationChanges(ReportManagerInitializer.java:169) ~[rpmgr.jar:?]

Environment

Release : 22.2.x

Cause

Due to custom files under %SPECROOT%/custom/repmgr/config files

Resolution

Under $SPECROOT/custom/repmgr/config move the files to tmp or any other folder 

Restart tomcat and check. If no changes, it has been reported by some customers that after reboot the server the SRM came up.

If upgrade failed then re-run the upgrade after moving the files from custom/repmgr/config