Not all resources are returned while searching on a page
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Not all resources are returned while searching on a page

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Article ID: 253073

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

The customer noticed that Users for example are disappearing from Default>All Resources>User page after being edited. If he searches for that User just modified, it returns nothing. 

Environment

ITMS 8.5, 8.6, 8.7

Cause

For this customer, he had 69,000 Users but only displaying 50,000 when searching.

 
This view is obeying the 'report-like' limit of the results to be able to see resources that are been searched.
The Default value is 50,000, and if the edited User will be after that limit - you'll not see it.
It always was like this, but the results are random in terms of "I can see or not", as the SQL queries may return rows in any order, what SQL server may see fastest.

Resolution

Change Core Setting - "ReportMaxRowCount" to a bigger value, like 1,000,000 (1 million) and you'll probably see the missing resource. See the following article for steps how to find the mentioned core setting:
 
156350 "SMP report results are restricted to 50,000 rows."
 
NOTE: If this works, follow the suggestions on the article to use other values for "ReportMaxRowCount" as needed.
 
Post-8.6 RU3:
 
Starting with our ITMS 8.7 Release, New Core Setting "OrgViewMaxRowCount" is available in UI and can be changed there.
This new core setting was added to control limits in Org Views & Groups. If this setting have a value (over 0), the limit is applied. When limit applied - warning is displayed on the Org View pages