Saving changes to Customer-specific URL category settings generates an Application error
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Saving changes to Customer-specific URL category settings generates an Application error

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Article ID: 252970

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Attempting to save changes to Spam > Customer-specific URL category settings the Messaging Gateway (SMG)

Reviewing the BrightmailLog.log shows an error similar to the following:

Oct 07 2022 13:41:27 [https-jsse-nio-443-exec-10] [ActionServlet] ERROR - null
java.lang.NullPointerException
        at com.symantec.smg.controlcenter.messagefiltering.policy.FilterPolicyManager.getReferencingPolicyNames(FilterPolicyManager.java:661)
        at com.symantec.smg.controlcenter.messagefiltering.spam.SpamAction.saveCategorySettings(SpamAction.java:380)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)

Environment

Release : 10.7.5 patch 10.7.5-292

Cause

A content policy with the action "Treat as spam" will cause the Customer-specific URL settings to generate a nullPointerException when saved.

Resolution

This issue has been addressed in the Messaging Gateway 10.8.1 release. If you are experiencing this exception, please upgrade at your earliest convenience to resolve the issue.

If you cannot upgrade, a potential workaround if you have a content filtering policy with the action "Treat as spam" is by setting the action to some other policy action like "Delete" or "Hold in Spam Quarantine"