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DataAggregator fails to start on new CA Performance Management installation with error : "kahadb is locked by another server"

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Article ID: 252904

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Updated On:

Products

DX NetOps CA Infrastructure Performance CA Performance Management - Usage and Administration

Issue/Introduction

After installing new a new DA, it will not start up correctly.

[[email protected] ~]$ systemctl status dadaemon
● dadaemon.service - Data Aggregator
   Loaded: loaded (/etc/systemd/system/dadaemon.service; disabled; vendor preset: disabled)
   Active: inactive (dead)

[[email protected] ~]$ sudo systemctl start dadaemon
Job for dadaemon.service failed because the control process exited with error code.
See "systemctl status dadaemon.service" and "journalctl -xe" for details.

The following is shown in it's activemq.log:

[[email protected] data]$ tail -f activemq.log

2022-10-18 09:55:03,247 | INFO  | Refreshing [email protected]: startup date [Tue Oct 18 09:55:03 AEDT 2022]; root of context hierarchy | org.apache.activemq.xbean.XBeanBrokerFactory$1 | main

2022-10-18 09:55:03,681 | INFO  | Using Persistence Adapter: KahaDBPersistenceAdapter[/opt/da-shared/broker/kahadb] | org.apache.activemq.broker.BrokerService | main

2022-10-18 09:55:03,683 | INFO  | Database /opt/da-shared/broker/kahadb/lock is locked by another server. This broker is now in slave mode waiting a lock to be acquired | org.apache.activemq.store.SharedFileLocker | main

Environment

DX NetOps CAPM Release : 22.2

Cause

Issue caused by install user not having full Read/Write permissions for the shared disk upon which the DA is installed

Resolution

Change the privileges for the install user account on the drive to R/W.