SSPI handshake failure connecting ICA application to the RiskFabric database
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SSPI handshake failure connecting ICA application to the RiskFabric database

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Article ID: 252853

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Updated On:

Products

Information Centric Analytics

Issue/Introduction

The following runtime error is displayed when attempting to load the Information Centric Analytics (ICA) console in any browser:

Server Error in '/' Application

Runtime Error

Description: An exception occurred while processing your request. The request has been terminated.

The RiskFabricAppPool is running in Internet Information Systems (IIS) and the license file is still valid, per KB article 222902.

The following SQL client error is logged in the RiskFabric server log:

ClientConnectionId:7aa98861-f076-49b1-9f42-b594160288e5
Error Number:18452,State:1,Class:14
2022-10-24 12:21:03,555 [1:ERROR] DALException.SaveLog() Caught exception, handling it in DALException
2022-10-24 12:21:03,556 [1:ERROR] DALException.SaveLog() System.Data.SqlClient.SqlException (0x80131904): Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.

The following errors are logged in the SQL Server log:

Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. [CLIENT: <host>]

SSPI handshake failed with error code 0x8009030c, state 14 while establishing a connection with integrated security; the connection has been closed. Reason: AcceptSecurityContext failed. The Windows error code indicates the cause of failure. The logon attempt failed. Error: 17806, Severity: 20, State: 14.

Environment

Release : 6.x

Component : Microsoft SQL Server

Cause

This error can be due to a misconfiguration in Active Directory or DNS and can occur consistently for local connections using trusted authentication when SQL Server’s SPN is not interpreted by SSPI as belonging to the local machine.

Resolution

If the connection was previously working and recently failed, restart the SQL Server service. If that does not resolve the issue, you will need to work with your internal AD and network teams to investigate Active Directory and SPNs.