MQMEM records increases when launching JOBF with Agents 12.3.9
search cancel

MQMEM records increases when launching JOBF with Agents 12.3.9

book

Article ID: 252834

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

On an Automation Engine version 12.3.8 since a month, normally the MQMEM current count is between 0 and 200, but suddenly is count spiked to 4.166, and increases with 100 new records every hour.

There is no performance issues noticed.

After investigation, with the help of this query to detect the orphan records in MQMEM:

SELECT MQMEM_PK, MQMEM_SYSTEM, MQMEM_TITLE, MQMEM_MQSET
FROM MQMEM
WHERE MQMEM_PK NOT IN (
SELECT MQMEM_PK
FROM MQMEM, EH
WHERE SUBSTR(MQMEM_TITLE, 36, 7) = 'AH_IDNR'
AND EH_AH_IDNR = SUBSTR(MQMEM_TITLE, 44, 10)
);

if was found that the records were caused by JOBF from one specific client that had been running for years  and had not been modified for a long time.

After disabling the impacted JOBF jobs, the MQMEM records stopped growing which confirmed this lead.

Environment

Automation Engine Release : 12.3.x

Agents Version: 12.3.9

Context: JOBF being launched on Agents 12.3.9 were generating orphan records on MQMEM table

Cause

Defect on Agents 12.3.9 related to JOBF

Resolution

 After upgrading all the Agents 12.3.9 to 12.3.9 HF1 the MQMEM count decreased immediately, problem solved.