search cancel

SCRT Report tool updated. What changes are required.

book

Article ID: 252831

calendar_today

Updated On:

Products

COMMON SERVICES FOR Z/OS

Issue/Introduction

IBM just updated their SCRT Tool to 29.1.

Trying to make sure that we can/should update our Broadcom SCRT report (CAISCRT) to reflect the upgraded SCRT tool or do we need to leave it at 28.1 for now?

If we are good to upgrade it can you also verify that the only real change we need to make in the parameters is; 

APP_HOME=/u/~userid~/scrtv291 from 281?

Environment

Release : 15.0

ISV SCRT Reporting

Resolution

The Broadcom ISV SCRT JCL can be updated to point to the newer IBM SCRT version.

The only necessary change is to update the APP_HOME value defined within the //STDENV DD section of CAISCRT JCL provided in CAW0JCL.

Additional Information

IBM documents that the Java prerequisite is "Minimum: Version 7 with all current maintenance (deprecated).

SCRT Version 28 is the last version of SCRT that will run in a Java 7 runtime environment.

IBM requires that you use the latest version of SCRT, which is referring the the Version and not Release.

IBM has recently released SCRT 29.1.0, which is now the latest version, and this does not support Java 7.

SCRT now requires Java 8 or later runtime environment. Java 7 is no longer supported.