search cancel

Data engine failed to insert data into database, the 'PRIMARY' filegroup is full

book

Article ID: 252738

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Data_engine probe and data engine queue are not processing any data to the database

 

Environment

Release : 20.3

Cause

Seen the following error in data_engine.log.

11196] 0 de: Commit - ERROR: Code=0x80004005 Source=Microsoft OLE DB Provider for SQL Server Description=Could not allocate space for object 'dbo.RN_QOS_DATA_0020'.'RN_QOS_DATA_0020_Idx0' in database 'CA_UIM' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.
Oct 21 14:48:30:891 [11196] 5 de: commit_thread - (COMMIT_THREAD_FAILED) commit failed,

Oct 22 11:54:44:394 [11048] 5 de:  data  bulk_size=2000 bulk_list=PPDS(1316216) qsize=53759 
Oct 22 11:54:44:394 [11048] 2 de: DataCallback - processed 0 messages, sending reply: temporarily out of resources (7) 
Oct 22 11:54:44:394 [11048] 5 de: SREPLY: status = 7(temporarily out of resources) ->10.76.1.29/48002  

Resolution

- UIM database was running out of resources, data engine probe is running but not processing any data.
- Check the database CPU, memory, and disk and make sure they have enough resources.
- Looking at the MS SQL server log and noticed the error it can not insert data due to the PRIMARY filegroup is full.
- Added a file to the primary filegroup. ( consult your DBA).
- Once the new file is created, activate the data_engine probe and the probe was able to insert data into the database.

 

Attachments