CCA-DIS-8518: Discovery failed on Server "xxx.xxx.xxx", Error message=com.maverick.ssh.ChannelOpenException: open failed.
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CCA-DIS-8518: Discovery failed on Server "xxx.xxx.xxx", Error message=com.maverick.ssh.ChannelOpenException: open failed.

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Article ID: 252684

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Updated On:

Products

CA Configuration Automation

Issue/Introduction

When we are running the discovery for linux servers redhat version 7 it discovers successfully but on version 8 it gives the following attached errors:

CCA-DIS-8518: Discovery failed on Server "xxx.xxx.xxx", Error
message=com.maverick.ssh.ChannelOpenException: open failed.

CCA-LN-1003: Failed to run ToUTF8 converter on server "XXX" for converting the results to UTF-8. 
Some dependent libraries like iconv might be missing on this server. Decoding the results using 
UTF-8 by default.

 

Environment

CA Configuration Automation - 12.9 version

Cause

The "SSH Channel Itself is not Opened":

The above error could occur due to Permissions issue, or firewall blocking the port. This error message 
means that remote SSH server was unable to perform TCP request because it couldn't connect to the 
target tunnel. 

 

Resolution

Check with the Unix Platform Administrator on this.  Enable logging in sshd and cca.log, can help to
get the actual root cause of the problem.