search cancel

SV: DevTest JBOSS Active MQ Connection not working

book

Article ID: 252627

calendar_today

Updated On:

Products

Service Virtualization

Issue/Introduction


I am not seeing JBOSS Active-MQ extensions just like IBM, Rabbit MQ. Can you please let me know how to test this?



 

Environment

Release : 10.7 and up

Cause

N/A

Resolution

Yes, we do support Active MQ for Devtest.  And Active MQ is usually just JMS

Two JAR files are required for deploying the JMS-based virtual service and must be copied into the DevTest directory.
Follow these steps:
 Download the following files from the Internet.
activemq-client-5.12.1.jar
hawtbuf-1.11.jar
Copy them to the following directory:
DEVTEST_HOME\hotDeploy

 

 

Steps to create the Assets: 

1. Create Active MQ Asset  in the project.config  -  Click on the + and add  DirectJMS ConnectionFactory for ActiveMQ
2.  Add a JNDI Context 
JNDI Factory Class: org.apache.activemq.jndi.ActiveMQInitialContextFactory
URL : ssl://yourhost:Port
Username:
Password:


Click the green arrow to Verify


3. Create a JMS Destination 

JMS-JNDI Queue
JNDI Context: same as you created
QueueName: dynamicQueues/LISAQ2
Note**  we need to put dynamicQueues/  in front of the queue or topic name. 

We are now able to verify the assets.   

https://techdocs.broadcom.com/us/en/ca-enterprise-software/devops/devtest-solutions/10-7/getting-started/service-virtualization-tutorials/tutorial-2-jms-virtual-service-using-devtest-portal.html#concept.dita_e668427d9702b13bf61925085226bcbf38660131_Step3CopyJARFiles

Attachments