ITL-0002: 'Target Resolution Date' should be same or earlier than 'Impact Date'.
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ITL-0002: 'Target Resolution Date' should be same or earlier than 'Impact Date'.

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Article ID: 252580

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

A RISK could happen in the future, while an ISSUE is considered to be happening right now.
RISKS turn into ISSUES if their mitigation strategy fails.

A RISK has an Impact date and a Target Resolution date and you want the resolution date to be BEFORE the Impact date, as you want it to be fixed before it becomes a problem.

Given that an ISSUE has an Impact date and a Target Resolution date, you expect that the Impact date is probably today or earlier, while the Target Resolution is probably somewhere in the future.

When you put a Target Resolution date AFTER the Impact date on an Issue, you receive the ITL-0002 error: 
ITL-0002: 'Target Resolution Date' should be the same or earlier than 'Impact Date'.

That error makes sense for a RISK, but not for an Issue.

Cause

In the current GA releases, an internal, OOTB business restriction is implemented between the Risk and Issue 'Impact Date' and 'Target Resolution Date' fields. When the user tries to enter the 'Target Resolution Date' AFTER the 'Impact Date', the following error occurs:

Error is thrown ITL-0002: 'Target Resolution Date' should be same or earlier than 'Impact Date'.

Resolution

This has been enhanced in 16.2.1 through the below feature

F31406: Risks & Issues: Option to Disable Target Resolution and Impact Date Logic

Description: Give the ability for System Admin to enable/disable business rule, in particular 'Target Resolution Date' should be same or earlier than 'Impact Date' in Issue, it will better support different organizational use cases.

In 16.2.1 a boolean setting will be available in Classic > Administration > Project Management > Settings > "Allow Risk and Issue Target Resolution Date to be greater than the Impact Date"

With the setting checked, the end user will be able to set the Target Resolution Date that would fall AFTER (or later) than the Impact Date.Applies to both MUX and Classic end users.Project, Idea, CIT, and Team Investment investment types Risk and Issues will be supported with this new optional setting

The setting to enable the end user (in both Classic and MUX) to set the "Target Resolution Date" that would fall AFTER (or later) than the "Impact Date" DOES NOT APPLY to Change Requests.