"Execute a Process" job completed, but process did not run
search cancel

"Execute a Process" job completed, but process did not run

book

Article ID: 252314

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

In Clarity, we have a custom job that executes a process. The job is completing as scheduled, but the process does not run.

Why can this happen?

 

 

Cause

There was a process instance stuck and the following job parameter was checked: Allow only one running instance

Resolution

The "Execute a Process" job does not wait for the process to finish. By design, it is only designed to call the associated process.

It automatically sets its status to Completed regardless of what happens to the process itself.

If multiple processes can run simultaneously, disable the Allow only one running instance option on the job