DMS Cannot Start, Failed to open Policy Model's subscribers database
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DMS Cannot Start, Failed to open Policy Model's subscribers database

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Article ID: 252158

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Updated On:

Products

CA Privileged Identity Management Endpoint (PIM)

Issue/Introduction

On a Windows Enterprise Management server, all services are started except for the DMS. In Event Viewer, the following error is seen when the DMS tried to start.

PMDB DMS__ Failed to open Policy Model's subscribers database: rv = 32519

Environment

Privileged Identity Manager 12.9

PAM Server Control 14.x

Cause

One or more of the subscriber data files in the DMS directory is corrupt.

Resolution

First, open the command prompt and stop the remaining services with the following command.
# secons -s

Next, browse to the DMS directory and delete the subscribers.* files.
For PAMSC: C:\Program Files\CA\PAMSCServer\APMS\PAMSC\Data\DMS__
For PIM: C:\Program Files\CA\AccessControlServer\APMS\AccessControl\Data\DMS__

Go back to the command prompt and start the services again.
# seosd -start

If the DMS service is stuck on Starting and the other services are Stopping, then the server needs to be rebooted in order for the services to be restarted properly as the DMS service is hung.

Once the services are running, go to the command prompt and run the commands below to add the subscribers back to the DMS.
# sepmd -smq DMS__ -predefined ServerToServerBroadcast -destination DH
# dmsmgr -sync self

If the environment has distribution servers, connect to each one and run the command below to sync with the DMS again.
# dmsmgr -sync self