"Dynamic categorization error: Too many queued connections." Errors in the Edge SWG Event Log
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"Dynamic categorization error: Too many queued connections." Errors in the Edge SWG Event Log

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Article ID: 252121

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Updated On:

Products

ProxySG Software - SGOS ISG Proxy

Issue/Introduction

While reviewing the appliance event log, the following error is observed:

"Dynamic categorization error: Too many queued connections"

Cause

Typically, this error results when there is a large volume of uncategorized traffic being proxied.



Resolution

The concept of the message is to inform that the WebPulse service is being overwhelmed with requests from the impacted appliances. These requests would need to be investigated (find out what site or sites are being sent for dynamic categorization) and then submitted for categorization through the BRCM Site Review portal. Once processed and categorized, the volume in frequency of errors should be expected to decrease given that affected destinations would then exist within the categorization databases.

Additionally, methods for troubleshooting these errors include combinations of the following:

  • Customer access log investigation of URLs that are being sent for dynamic categorization. 
  • Collection and review of proxy OPP Debug logs while the issue is experienced (https://proxyIPaddr:8082/OPP/debug)
    • Note: This step is to be recommended by support and debug variables should be cycled off once troubleshooting has completed.
  • Backend investigation based on appliance serial for the determination of unusual traffic patterns or behavior (based on available logs and conducted by Support). 
  • Collection of SWG core to be submitted for ENG review (as recommended by support).