Unable to see the Conversations under Task or RIC
search cancel

Unable to see the Conversations under Task or RIC

book

Article ID: 252084

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Conversations are erroring out under CITs for users who are non admins

 

Environment

Release : 16.0.3

Cause

1. Login as an admin and navigate to Objects
2. Create a new object which is of type Custom Investment - Name: Business Outcomes
3. Navigate to MUX --> CIT --> Business Outcomes
4. Create a new instance under Business Outcomes. Name: Funding
5. Click on Funding and navigate to Task tab
6. Create a new task Name: Govt Fund 
7. Click on the Task Gove Fund and open the Details Flyout window and click on Conversations tab
8. Type some message in Conversations tab and Post
Expected and Actual: The message is posted. 
9. Navigate to Administration - Users and click New
10. Create a new user named Tester and assign the below rights
    Global Rights: Custom Investment - Navigate 
                Custom Object - Navigate 
       Business Outcomes - Create
       Business Outcomes - Task Management - All
       Business Outcomes - View All
       Projects - Navigate 
       Tasks - Navigate 
       
11. Logout and login as Tester user
12. Navigate to   MUX - Business Outcomes - Funding - Govt Fund
13. Click on Govt Fund task and open the Details flyout
14. Click on Conversation tab and type a message and hit Post

Expected Results: The message is posted successfully.

Actual Results: The below error message is thrown
API-1007 : You are not authorized to process request. Contact your system administrator for necessary security rights.

Workaround: 
Grant Project - View Management - All global rights. 

Resolution

DE66848 - Fixed in 16.1.0