Unable to export xlsx files in 17.3RU17
search cancel

Unable to export xlsx files in 17.3RU17

book

Article ID: 252058

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

Unable to export xlsx files.  Content is exported as .xls files instead.

Environment

Release : Service Desk Manager (SDM) 17.3 RU17

Cause

Manual post install tasks not completed to enable .xlsx 

Resolution

First verify that files ahdtop.html, export.js and std_list.js have a date of 09/12/2022

ahdtop.html is located inside C:\Program Files (x86)\CA\Service Desk Manager\bopcfg\www\htmpl\default

export.js and std_list.js are located inside of C:\Program Files (x86)\CA\Service Desk Manager\bopcfg\www\wwwroot\scripts

The purpose of this is to validate installation.

 

Open command prompt as administrator and run the commands:

pdm_options_mgr -c -s use_legacy_export -v "No" -a pdm_option.inst

pdm_options_mgr -c -s use_legacy_export -v "No" -a pdm_option.inst -t

Restarted Service Desk service

Clear the cache 

The exported data file will be .xlsx 

  

 

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/ca-service-management/17-3/installing/Installing-CA-Service-Management-17-3-0-17/Post-Installation-Tasks-for-CA-Service-Management-17-3-0-17.html

Updated pdm_exporter.exe will be included inside of  17.3RU18

Defects DE66696 and DE66697