Enabling Agent debug causes Agent error : Agent is Unavailable : null
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Enabling Agent debug causes Agent error : Agent is Unavailable : null

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Article ID: 251940

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

When enabling Agent debug for all agents from the client interface using the steps Help>About Applications Manager>Debug>Agents the following error can be seen...

Agent error : Agent is Unavailable : null

Review of the RmiServer log will show the complete message including the agent which is unavailable.

07:22:41.253 CR0 10.0.0.1:1705: .AxOptions: NoErrorMsgProperties=false
ErrorMsg: AwE-5128 Client Request Error (10/12/22 7:22 AM)
Details: toggleAgentDebug
Agent error : BANNER : Agent error : Agent is Unavailable : null

In the example above the agent which is unavailable is named "Banner"

Environment

Release : 9.3 and 9.4

Cause

This is caused when an agent is defined in the client gui but is set to inactive. 

Resolution

This is a warning message to alert users that when setting debug for all agents the debug will not be enabled for inactive agents.