Unable to login to policy manager after upgrade
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Unable to login to policy manager after upgrade

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Article ID: 251899

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Updated On:

Products

CA API Gateway

Issue/Introduction

We are unable to login to policy manager after doing an installation of 10.1 version.

 

Environment

Release : 10.1

Cause

Cause:

The issue was the listening port used for PM on the 9.3 ONLY have TLS 1.0 selected

 

After importing SSG DB from 9.3 to 10.1

Updating SSG DB 

Failed to access Policy Manager

SSL TLS exception

Policy Manager exception

WARNING: Could not connect to admin service server

org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [https://securespangateway/ssg/manager/AdminLogin]; nested exception is javax.net.ssl.SSLHandshakeException: Remote host terminated the handshake

at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.convertHttpInvokerAccessException(HttpInvokerClientInterceptor.java:234)

at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.invoke(HttpInvokerClientInterceptor.java:160)

at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:186)

at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:215)

at com.sun.proxy.$Proxy6.getServerCertificateVerificationInfo(Unknown Source)

at com.l7tech.console.security.d.call(Unknown Source)

at com.l7tech.gateway.common.spring.remoting.http.SecureHttpComponentsHttpInvokerRequestExecutor.doWithSession(Unknown Source)

at com.l7tech.console.security.c.call(Unknown Source)

at com.l7tech.gateway.common.spring.remoting.http.SecureHttpComponentsHttpInvokerRequestExecutor.doWithTrustFailureHandler(Unknown Source)

at com.l7tech.console.security.SecurityProviderImpl.a(Unknown Source)

at com.l7tech.console.security.SecurityProviderImpl.login(Unknown Source)

at com.l7tech.console.panels.by.construct(Unknown Source)

at com.l7tech.gui.util.au.run(Unknown Source)

at java.base/java.lang.Thread.run(Unknown Source)

Caused by: javax.net.ssl.SSLHandshakeException: Remote host terminated the handshake

Resolution

Update/enable the 9.3 listening port for Policy Manager for TLS 1.0, 1.1, 1.2 

Export SSG DB

Import SSG DB 

Updating SSG DB 

Truncate cluster_info table in SSG DB 

Start gateway 

Successfully access policy Manager