Error 400 seen when logging in to Clarity SaaS via SSO
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Error 400 seen when logging in to Clarity SaaS via SSO

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Article ID: 251807

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Updated On: 01-27-2025

Products

Clarity PPM SaaS

Issue/Introduction

After enabling SSO in our Clarity SaaS environment, some users are unable to log in despite being authenticated by our IDP (Azure).

The error '400 Login Failed - 400 Bad Request Error Code - GENERAL_NONSUCCESS' is seen when attempting to log in to Clarity.

Environment

Clarity 16.0.x, 16.1.x, 16.2.x, 16.3.x.

Cause

  • The user record in your user directory is missing some attributes that are required (firstName, lastName, Email). These need to be sent by the IDP
  • This could also be caused if the certificate at the directory is different from the one that was shared before with Clarity SaaS

 

Resolution

  • Ensure that the required attributes (firstName, lastName, Email) exist for the user in your user directory (e.g. Azure)
  • After setting the required parameters in the directory, the user should be able to login successfully
  • Ensure that there has not been any changes to the certificate.

Additional Information