Unable to access management console
search cancel

Unable to access management console

book

Article ID: 251806

calendar_today

Updated On:

Products

CA Identity Manager

Issue/Introduction

See the following error which results IDM management console is not able to access.

Exception handling request to /iam/immanage/: java.util.ServiceConfigurationError: org.apache.logging.log4j.spi.Provider: Provider org.apache.logging.log4j.core.impl.Log4jProvider not a subtype

ERROR [io.undertow.request] (default task-1) UT005023: Exception handling request to /iam/immanage/: java.lang.NoClassDefFoundError: Could not initialize class com.netegrity.ims.manage.filter.ManagementConsoleAuthFilter

Environment

Release : 14.4 Identity Manager

Cause

There was a mix version of jars from the previous install before the upgrade which were not deleted.

Resolution

Remove extra jars under ..\standalone\deployments\iam_im.ear\management_console.war\WEB-INF\lib from the previous upgrade