After boot of computer a reboot is performed without user notification
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After boot of computer a reboot is performed without user notification

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Article ID: 251737

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Software Delivery

Issue/Introduction

Computer starts and after some minutes, a reboot is performed without user notification.

Environment

Client Automation - All Versions

Cause

Problem could occur with following scenario :
 
1- Computer starts and caf is started.
2- cfregister is executed and am and sd agents are executed as post registration tasks
3- sd agent executes a SD Job which has reboot option enabled. As no there is no logged user. No caf reboot dialog box is displayed and reboot should be performed immediately
4- caf waits that amagent process is terminated before performing the reboot
5- User logs on. There is no indication that caf will reboot the computer soon. He starts to work during some minutes.
6- amagent is terminated and caf performs the reboot.

Resolution

There are multiple solutions to minimize the risk to have above scenario.

Solution 1 :

Delay the startup of caf and hmagent services by executing these commands on the computers
 
sc config hmagent start= delayed-auto
sc config caf start= delayed-auto
 
This could be done using a SD or AM job.
 
caf will be started later during boot process and this gives more chance to user to be logged in when SD Job with reboot is executed. (and so has the caf reboot dialog box displayed).
 
 
 
Solution 2 :
Execute following command on the computers to avoid SD Agent execution after caf register execution :
 
ccnfcmda -cmd SetParameterValue -ps itrm/agent/solutions/usd_agent -pn postregistrationplugin -v ""
 
SD Agent will automatically be executed when it received the SD Trigger sent by the scalability Server (every 10 minutes in case of pending SD job) or via the scheduler task sdagentschedule 
 
 
Solution 3 :
Check the scheduling options of collect Task of AM Agent (specially Software Inventory as it could take time to be executed). And check if scheduling options could be updated to minimize the AM Agent execution time after the boot of computer.
For example if software inventory is scheduled once a day, maybe change it to once a week.
Or define a time range (ex: between 12pm and 8pm)
 
The goal is to speed up the execution of AM Agent after the first computer boot. caf will perform the reboot (requested by SD Agent job) more quickly and user may has no time to logon or to start to work.
 

Additional Information

Solution 1 and 2 could be applied using a AM Job of type command.

Here is an example for solution 2

1- Create a new Asset Jobs of type “Command”:
 
 
Click Next
 
 
2- Give a name to the job. Ex: Remove sdagent postregistrationplugin
https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=rpp8M4bM04y/h1dOsVCuYw==
Click Next
 
 
3- In command textbox put this line:
ccnfcmda -cmd SetParameterValue -ps itrm/agent/solutions/usd_agent -pn postregistrationplugin -v ""
 
Click Next
 

4- In Scheduling options, put “Run only once”:

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=648884062381
And make sure that “This job is allowed to run unattended” is checked under Miscellaneous tab

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=648878001794

5- Then assign this job to all machines