API Connection to Enforce - Issue with Form based vs SAML authentication
search cancel

API Connection to Enforce - Issue with Form based vs SAML authentication

book

Article ID: 251733

calendar_today

Updated On:

Products

Data Loss Prevention Endpoint Prevent

Issue/Introduction

The customer configured PROD environment to integrate with ServiceNow DLP Incident Response integration with Symantec. Part of this configuration is to prepare API user to use later on both parties, however, there were errors.

1. Error on ServiceNow:

2. Error in tomcat logs on Enforce:

File: localhost.2022-09-22 (1).log
Date: 22.09.2022 13:45:20
Thread: 2192
Level: WARNING
Source: com.symantec.dlp.login.spring.SymantecFormAuthenticationProvider
Message: Form based authentication failed: username=ServiceNow_PROD

 

Environment

Server: Dala Loss Prevention Enforce with SAML
3rd party application: DLP Incident Response integration with Symantec

Cause

Most likely a typo in the password.

Resolution

Confirmed configuration on both parties and re-try. This time integration worked