Server not in Agent Administration after IP Address Changed
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Server not in Agent Administration after IP Address Changed

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Article ID: 251671

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio)

Issue/Introduction

Agent IP address has changed. We have deleted the agent from agent management. After updating the agent's nimi_config.xml's file to use the new IP Address (via /config/nimi/network/listen_address), we restart the agent and now the agent is not reappearing in Administration -> Agent Management. 

Environment

Release : 6.7

Component : CA RELEASE AUTOMATION AGENT

Cause

The Agent's nimi_config.xml /config/nimi/general/node_id was set to a different machine's hostname. 

Resolution

Update the agent's nimi_config.xml file's /config/nimi/general/node_id entry to use the hostname of this server. 

  • This should be unique and is typically the name of the server.
  • Stop/Start the agent. 
  • Now the agent is showing up in Agent Management.