Unable to start the Symantec DLP Detection Server service with the error: "Error 2: The system cannot find the file specified".
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Unable to start the Symantec DLP Detection Server service with the error: "Error 2: The system cannot find the file specified".

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Article ID: 251435

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Updated On:

Products

Data Loss Prevention Data Loss Prevention Endpoint Prevent

Issue/Introduction

The detection server status shows "Unknown" on the System > Servers and Detectors > Overview page on the Enforce console. On the Detection server, the Symantec DLP Detection Server Service is not running. Attempting to start it manually throws an error "Windows could not start the Symantec DLP Detection Server Service on Local Computer. Error 2: The system cannot find the file specified".

Environment

Data Loss Prevention 15.x

 

Cause

The ImagePath value for the Symantec DLP Detection Server Service contains double quotes after applying an update for VMware tool 12.1. A system with VMware tool 12.0 does not have this issue. 

Resolution

1. Open the Windows registry editor with administrator privileges on the Detection server by going to Start > Run > regedit.

2. Navigate to the Symantec DLP Detection Server Service under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services

3. The ImagePath value will be "<Installation drive >:\Program Files\Symantec\DataLossPrevention\Detectionserver\Services\SymantecDLPDetectionServer.exe -s SymantecDLPDetectionServer.conf"

4. Set the ImagePath value to "<Installation drive>:/Program Files\Symantec\DataLossPrevention\Detectionserver\Services\SymantecDLPDetectionServer.exe" -s SymantecDLPDetectionServer.conf

5. Start the Symantec DLP Detection Server Service manually and it should start successfully.