The following error is displayed under the SQL Server Configuration on the Data Sources page of the Symantec ICA Installation Wizard after entering the Server hostname and clicking the Connect button:
Connection Error SQL Server was not discovered. Check the server name.
Environment
Release : 6.x
Component : Microsoft SQL Server
Cause
This error occurs when the Information Centric Analytics (ICA) installer is unable to query the specified SQL Server host. This can be caused by any of the following conditions:
The provided server hostname or IP address is incorrect
The SQL Server service is not running on the target host
The SQL Server service is listening on a non-standard port and that port number was not provided in the server connection string
The Windows user account under which the installer is running has not been assigned sufficient privileges in SQL Server to query the master database
Resolution
To resolve the conditions listed in the Cause section of this article, refer to the following:
Confirm the server hostname or IP address is correct and, if a named instance is being used, include the instance name in the Server connection string using the following format:
<hostname>[\<instance>]
For example: mssql.example.com\ica
To confirm the SQL Server service is running for the target instance, follow this procedure:
From the Windows Start menu, open the SQL Server <version> Configuration Manager
Under SQL Server Configuration Manager, select SQL Server Services
Locate the SQL Server instance to which the ICA database (RiskFabric) will be installed Default instance: (MSSQLSERVER) Named instance: (<instance-name>)
If the instance is in a stopped state, right-click the instance name and select Start
If using a non-standard port for the SQL Server service, specify the port number in the Server connection string using the following syntax:
<hostname>[\<instance>],<port>
For example: mssql.example.com,1480 or mssql.example.com\ica,1480
Per the Symantec Information Centric Analytics Administrator Guide, the account under which the Symantec ICA server installation wizard runs requires both Microsoft Windows administrator privileges on the IIS (application) and SQL host servers, and the SQL system administrator (sysadmin) role in SQL Server. For more information, refer to the Required Installation Privileges and Credentials section of the guide.
Additional Information
The following utilities are recommended for troubleshooting this error:
telnet
Use to confirm target servers are reachable from the host on which the ICA installer is being run
Wireshark
Use to trace the communication packets between the source and target servers
SQL Server Profiler
Use to inspect the calls and responses processed by the SQL Server database engine
The ICA installer verifies the target SQL Server is reachable and running a supported edition of SQL Server (Enterprise or Developer Edition) by executing the following queries:
exec sp_executesql N'IF OBJECT_ID(''master..sysdatabases'') IS NULL EXEC sp_executesql N''select name as database_name, dbid, crdate as create_date from sysdatabases where (name = @Name or (@Name is null))'',N''@Name NVARCHAR(128)'',@Name=@Name ELSE EXEC sp_executesql N''select name as database_name, dbid, crdate as create_date from master..sysdatabases where (name = @Name or (@Name is null))'',N''@Name NVARCHAR(128)'',@Name=@Name',N'@Name nvarchar(4000)',@Name=NULL
These queries should be seen in both a SQL Server Profiler trace and a network packet capture: