VIP Enterprise Gateway Services fail to start after migrating the server
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VIP Enterprise Gateway Services fail to start after migrating the server

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Article ID: 251015

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Updated On:

Products

VIP Service

Issue/Introduction

Changing the subnet or IP address (re-IP) of the VIP Enterprise Gateway Server causes a failure of the VIP Services to start. 

Cause

VIP Enterprise Gateway IP addresses are written to configuration files when the service is created. 

Resolution

Prior to the server re-IP or subnet change, or hostname\DNS change, export VIP EG settings. After the change, import the settings. The 'import' process strips the existing IP address from the configuration files and replaces it with the current. This will create new Validation Servers with the updated data. The non-functioning Validation Servers can be deleted. 

If you have already made the changes but the Exported data with the original settings is not available to import, the Validation Server configuration files can be manually updated with the new IP address. (note: Editing the RADIUS Validation server from the console page may allow the Validation server to restart, but it may not restart the next time that it is stopped.)

  • Stop the Validation server from the VIP EG console.
  • Delete the radserv.conf.working file from the <VIP_EG_install>\Validation\servers\<server_name>\ conf folder.
  • Open the radserv.conf file in the same folder with Notepad or another text editor. Locate and update the IP address or subnet, then save the file.
  • Start the Validation server from the VIP EG console.
  • Repeat for all Validation Servers. 

  • For the VIP SSP\MyVIP, stop VIP SSP Service from the VIP EG Console.
  • Delete any jetty folders from the <VIP_EG_Install>\IDP\services\SSP\ folder. 
  • Delete the contents of the <VIP_EG_Install>\IDP\services\SSP\conf folder. (do not delete the conf folder)
  • Start VIP SSP Service. You may receive an expected message that the service already exists. Deleted files are recreated when the service starts

  • For the VIP Manager IdP, stop VIP Manager IdP Service from the VIP EG Console.
  • Delete any jetty folders from the <VIP_EG_Install>\IDP\services\VIPMGR\ folder. 
  • Delete the contents of the <VIP_EG_Install>\IDP\services\VIPMGR\conf folder. (do not delete the conf folder)
  • Start VIP Manager IdP Service. You may receive an expected message that the service already exists. Deleted files are recreated when the service starts

  • DNS Changes may affect the validity of existing VIP EG SSL certificates . If so, create and import new SSL certificates.