Resolved Issues with the DCS Solaris Agent version 6.9.0.371
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Resolved Issues with the DCS Solaris Agent version 6.9.0.371

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Article ID: 251005

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Updated On:

Products

Data Center Security Server Advanced

Issue/Introduction

Resolved issues in 6.9.0.371
Last Updated September 28, 2022

Environment

Solaris 11.4 running the Data Center Security 6.9.0.361 Agent with IPS feature enabled

Cause

In the 6.9.0.361 Solaris Agent the *at syscall required additional handling for Solaris 11.4

Resolution

 
Resolved issues of the Agent
Issue
Resolution description
In a specific scenario, a kernel panic was observed on Solaris 11.4
Fix to handle all *at syscalls, whereby if the starting file descriptor != AT_FDCWD, we hold the ref count while performing access checks of the file or directory.
 
Note: To use this new Agent, the prior version must be uninstalled and the machine rebooted. The new Agent can then be installed, and the machine rebooted again to load the drivers. Please reach out to Support for the agent-solaris11-sparc.bin installation file. 

Details on Agent installation can be found in the following online help page:
https://techdocs.broadcom.com/us/en/symantec-security-software/endpoint-security-and-management/data-center-security-(dcs)/6-9/installing-upgrading-v127913953-d3608e151987/installing-the-agent-on-a-unix-computer-v127943380-d3608e163692.html

Details on uninstalling the Agent can be found in the following KB document:
https://knowledge.broadcom.com/external/article/218724/uninstalling-data-center-security-server.html
Or in the following online help page: https://techdocs.broadcom.com/us/en/symantec-security-software/endpoint-security-and-management/data-center-security-(dcs)/6-9/installing-upgrading-v127913953-d3608e151987/uninstalling-agents-using-package-commands-v127943976-d3608e165404.html