On Domains with CIC not installed, after installing CU4 99111508, dsmver don't report CU4 installed.
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On Domains with CIC not installed, after installing CU4 99111508, dsmver don't report CU4 installed.

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Article ID: 250948

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Updated On:

Products

CA Client Automation - IT Client Manager

Issue/Introduction

On Domains with CIC not installed, after installing CU4 99111508, dsmver don't report CU4 installed.

In those cases, the applyptf.log, has this error in it:


" ... Executing SYSCMD  command = PostInstallScript.bat
      PostInstallScript.bat - Error executing system command. Continuing...
      Done.
... "

And at PostInstall.log, these are the last lines of the it:

"...
       Starting tomcat...
       The DSM service was started as instance 'tomcat'.
       Command completed successfully.
       "Wait time 120 seconds..."
       "Restarted CAF TOMCAT service succesfully after copying the configuration files ."
..."

This behaviour only seems to happen when you don't have CIC installed because looking at a server that has CIC installed, these were the last lines of the postinstall.log:

"...
     "Updating agent version information ... "
     The operation completed successfully.
     "Post installation steps completed."
..."

 


 

Environment

Release : 14.5.CU4

Component : CA Client Automation

Cause

I was able to replicate this behaviour on my VMWare, and to figure out what is going on, I changed the 99111508.jcl removing the PostInstallScript.bat entry, and after running applyptf, I ran the PostInstallScript.bat manually without the @echo off entry at the beginning of the batch. From that, I got these message:
\CA\DSM\ was unexpected at this time.
 
It seems that the script fails on line 118 (cd %ITCMINSTDIR%). This command is inside the IF EXIST %CICINSTDIR% (line 103), responsible for checking whether or not the CIC exists on the server.
 
Outside the "IF EXIST" this command works fine as we don't get any error on line 42, but inside it seems it can't parse the DSM folder spaces and fails.

 command on line 118 will only fail if the variable %CICINSTDIR% from IF EXIST %CICINSTDIR% is empty. If the CIC Manager exists in the registry, line 118 does not give an error.
 
This is why this error is only happening on servers where CIC is not installed.

 

Resolution

Workaround with current CU4 : By changing line 118 by adding quotes (cd "%ITCMINSTDIR%"), everything seems to work in both cases, i.e. with CIC or without CIC installed.

This will be resolved in upcoming CU5 .