Browser is getting crashed while loading Configure option in Portal
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Browser is getting crashed while loading Configure option in Portal

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Article ID: 250897

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

After upgrading a Project version in TDM Portal 4.1.72.0, we are experiencing an error in the Chrome Browser.

When trying to load configure page (tags-wise option) – TDM crashes the Chrome browser with an out of memory error.  The CA Test Data Manager Portal service never crashes. To recover we only need to reopen the browser and reconnect to TDM Portal. If we select the original project version, the issue is not seen.

Environment

Release : 4.10

Component : TDM Web Portal

Cause

This is related to DE546763, where the project upgrade creates an excessive number of masking functions per tag.

The root cause is a result of the browser trying to display too many elements on a single page, which in turn causes the browser to run out of memory and crash.

Resolution

This issue is also addressed by upgrading to TDMWeb-4.10.98.0.

Once the Portal is upgraded, you will need to upgrade the project again, from the original project version.

It's recommended to delete those earlier project versions, that contain an excessive number of elements and cause the browser to crash.