LDAP based administrator account unable to log into Messaging Gateway Control Center
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LDAP based administrator account unable to log into Messaging Gateway Control Center

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Article ID: 250798

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Updated On:

Products

Messaging Gateway

Issue/Introduction

When attempting to log into the Messaging Gateway (SMG) Control Center, an LDAP based administrator account is unable to log in and the following warning is generated in the Directory Data Service (DDS) logs:

WARNING: [building membership: DDS_SOURCE] failed to find child member (cn=users,ou=administrators,dc=example,dc=com) while expanding (cn=smg_administrators,ou=groups,dc=example,dc=com)

Environment

Release : 10.7 or newer

Component : Directory Data Service

Cause

When expanding the configured LDAP based administrator group, the user attempting to log in was not found in the group. This issue is usually caused by changes to the administrator LDAP group or user account in Active Directory / LDAP which have not fully propagated or conflicting information in cached in the SMG Control Center DDS cache.

Resolution

This issue can usually be resolved by resetting the Directory Data Service (DDS) cache for the DDS source which is handling BCC Authentication.

The reset / empty the DDS cache:

  1. Log into the SMG Control Center using an account with Full Administrator privileges
  2. Go to Administration > Directory Data Service
  3. Open the directory data source which handles BCC Authentication
  4. Open the "Advanced" tab
  5. Click the "Clear Cache"
  6. Confirm by clicking "Continue"