Location Awareness does not work anymore
search cancel

Location Awareness does not work anymore

book

Article ID: 250693

calendar_today

Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Location Awareness function does not work anymore on the computers. The scalability server is not changed even if a rule exists for the ipaddress
 
In TRC_CF_REGISTER log on the agent in trace DETAIL level no rule are found in the location awareness table.
 
210922-16:54:25.6588291L|010992|00001104|cfRegister|TraceRules | |000000|DETAIL | TraceRules starts
210922-16:54:25.6588984L|010992|00001104|cfRegister|TraceRules | |000000|DETAIL | TraceRules ends
 
Normally all rules should be found and displayed in the logs :
 
210922-18:09:09.8787649L|000800|000012ac|cfRegister|TraceRules | |000000|DETAIL | TraceRules starts
210922-18:09:09.8788023L|000800|000012ac|cfRegister|LARule::Trace | |000000|DETAIL | Rule start
...
210922-18:09:09.8791647L|000800|000012ac|cfRegister|LARule::Trace | |000000|DETAIL | Rule end
210922-18:09:09.8791877L|000800|000012ac|cfRegister|LARule::Trace | |000000|DETAIL | Rule start
...
210922-18:09:09.8798799L|000800|000012ac|cfRegister|LARule::Trace | |000000|DETAIL | Rule end
210922-18:09:09.8799017L|000800|000012ac|cfRegister|TraceRules | |000000|DETAIL | TraceRules ends


Problem starts after installation of 14.5 CU* patch on the Agent

Environment

Client Automation 14.5 + CU* patch

Cause

Before CU1 patch, a location awareness rule has 6 parameters :
name, range, priority, scan, script, server
 
Starting CU1, a location awareness rule has 2 new parameters :
Alt Server, Pack Size
 
 
But if Configuration Policy with Location Awareness Table was not updated since installation of CU* patch on Domain Manager, the Agents have still the Location Awareness Table with the 6 parameters in comstore.
When "caf register" on Agent 14.5 CU* reads the Location Awareness Table from comstore, it ignores the rules with only 6 parameters as it expects 8 parameters.
So no valid rule are found and Location Awareness does not work as there is no rule.
 
 
To check how many parameters are in Location Awareness Table rule on Agent comstore, execute this on the Agent :
dsmdiag -c dsmdiag.txt
 
Open the file dsmdiag.txt, research name="loc1" and check how many parameters there are into the rule :
<paramsection name="loc1">
<parameter name="script" entity="Manager" value=""/>
<parameter name="subnet scan" entity="Manager" value=""/>
<parameter name="scalability server" entity="Manager" value="ssname_test"/>
<parameter name="address range" entity="Manager" value="1.2.3.4 - 1.2.3.10"/>
<parameter name="priority" entity="Manager" value="5"/>
<parameter name="location name" entity="Manager" value="TEST Rule"/>
</paramsection>
 
Valid CU* rule has 8 parameters :
<paramsection name="loc1" orgname="Loc1">
<parameter orgname="Location Name" name="location name" entity="Manager" value="TEST Rule"/>
<parameter orgname="Priority" name="priority" entity="Manager" value="5"/>
<parameter orgname="Address Range" name="address range" entity="Manager" value="1.2.3.4 - 1.2.3.10"/>
<parameter orgname="Scalability Server" name="scalability server" entity="Manager" value="ssname_test"/>
<parameter orgname="Subnet Scan" name="subnet scan" entity="Manager" value=""/>
<parameter orgname="Script" name="script" entity="Manager" value=""/>
<parameter orgname="Alternate Scalability Server" name="alternate scalability server" entity="Manager" value=""/>
<parameter orgname="Maximum Package size" name="maximum package size" entity="Manager" value="0"/>
</paramsection>

Resolution

1- Unseal the Configuration Policy containing the Location Awareness Table.
2- Go under DSM/Agent/Common Agent/Common/Location Awareness and doble click on Locations
3- Add a rule in the table and click OK
4- Doble click again on Locations and remove the rule. Click OK
5- Seal the Configuration Policy
 
Domain Manager will send the configuration policy with 8 parameters for Location Awareness rules