Upgrade to 9.4.2 fails on CHANGE_MASTER_NAME Updating old to new values
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Upgrade to 9.4.2 fails on CHANGE_MASTER_NAME Updating old to new values

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Article ID: 250635

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

The following error is seen when running the 9.4.2 installation against existing data.

****  Automation Engine, Ip, User name, Oracle id - Do not match *****
      old_master=APWXQA  master=APWXQA
      old_ip=test12345.com ip=test678910.com
      old_user=APPWORX user=APPWWORX
      old_oracle_id=appworx oracle_id=appworx
      old_net_connect=@test net_connect=@test
Change Database to new values                      [N] ?Y

CHANGE_MASTER_NAME =       Updating old to new values
Fatal Error occurred - check the log /appworxdv/usr/install/aw_install.log

Cause

This error occurs during installation against existing data if there are any changes made to the master name, ip, os user, oracle id, or net_connect.

As you can see from the above example excerpt from the aw_install.log, the installation detected that there was a change to the master ip address. When a difference is detected, you will generally be prompted to "Change Database to new values" to which you should enter in Y for yes. However, in 9.4.2 this causes the installation to fail. . If there are no changes to the Master, IP, User, Oracle_ID, or net_connect values, then you shouldn't run into this issue.

Resolution

This issue has been resolved in Applications Manager 9.4.2 Hot Fix 1. Please download the 9.4.2 HF1 from Automic Download Center - Component Downloads and run the installation to resolve the issue.