Slowness in AWI to display Executions and Last Report on Agents and Processes
search cancel

Slowness in AWI to display Executions and Last Report on Agents and Processes

book

Article ID: 250603

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

When upgrading to a more recent version of Automic, the following message asked to rebuild the index NK_AH_IDNR_bearb, which was done:

  • Message U00038042 Action required! Check index NK_AH_IDNR_bearb if it matches the definition in uc_ddl.sql

    If the DB Load log includes this message, you have to update the NK_AH_IDNR_bearb index manually by dropping the index and copying the matching create statement from the uc_ddl.sql because an automatic update could take a long time. However, you do not have to do it during DB Load, you can do it at a later point in time.

This led to a slowness that could be observed while clicking on Monitoring -  "Last Report" or "Executions" while selecting an Agent or  Automation Engine Management - Processes.

For example, this operation takes 1 second with the old definition of the Index NK_AH_IDNR_bearb, but it takes 9 seconds with the newer definition.

Environment

Release : 12.3.x and 21.x

Component : AUTOMATION ENGINE

Cause

Defect: some XREQ queries did not include the AH_CLIENT which provoked that the newer definition of NK_AH_IDNR_bearb would not be used.

Resolution

Solution:

Update to a fix version listed below or a newer version if available.

Fix version:
Component(s): Automation Engine

Automation.Engine 21.0.5 - Available

 

Workaround:

In order to retrieve the same old performance, please Rollback to the previous definition of the Index NK_AH_IDNR_BEARB.

Example of commands for the AUTOMIC schema on an ILM Oracle system:

DROP INDEX AUTOMIC.NK_AH_IDNR_BEARB;
CREATE INDEX AUTOMIC.NK_AH_IDNR_bearb ON AUTOMIC.AH(AH_Client, AH_OH_Idnr, AH_OType, AH_TimeStamp1 DESC, AH_TimeStamp4, AH_Idnr) LOCAL ONLINE
TABLESPACE "UC4_INDEX" ;

Additional Information

Defect ID: AE-29464

Solution Details: A problem has been fixed where the statistics queries did not reflecting the new index on archive header(AH) data.