Process Step with escalation rules, and action items, fails
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Process Step with escalation rules, and action items, fails

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Article ID: 250488

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Running a Process having an Action item step with Escalation rules fails.

Following error is noticeable in the Process logs:

"BPM-0543: An error occurred when sending the action item. Contact your site administrator. {0}".

Following error is noticeable in the bg-ca.log:

ERROR 1996-10-07 13:65:07,069 [Action Execution Pipeline 0 (tenant=clarity)] niku.njs (clarity:process_admin:session:none) () Error getting job 50160
com.niku.union.exceptions.SchedulerException: No such job with id 50160
    at com.niku.njs.JobImpl.internalRetrieveJob(JobImpl.java:790)
    at com.niku.njs.JobImpl.retrieveJob(JobImpl.java:903)
    at com.niku.njs.SchedulerImpl.get(SchedulerImpl.java:871)
    at com.niku.bpm.escalation.EscalationServiceUtils.getEscalationJob(EscalationServiceUtils.java:96)
    at com.niku.bpm.escalation.EscalationServiceUtils.rescheduleEscalationJob(EscalationServiceUtils.java:43)

If we remove the escalation rules from the step the process executes as expected.

Environment

  • Release : 16.2.3

Cause

This is caused by Missing scheduled Job Templates (records in cmn_sch_jobs table) of the following jobs:

  1. Escalation
  2. Reschedule Escalation Job

Resolution

Run the following query to identify if you have the scheduled JOB Templates or not.

select
    *
from
    cmn_scH_jobs
where
    job_definition_id in (
        select
            id
        from
            cmn_sch_job_definitions
        where
            job_code in (
                'BPM_ESC_ESCALATION',
                'BPM_ESC_RESCHEDULE_ESC_JOB'
            )
    );

If the query doesn't return any records, please reach out to Broadcom Support.