EEM igateway service - unable to load jvm
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EEM igateway service - unable to load jvm

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Article ID: 250341

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Updated On:

Products

CA Workload Automation AE - Scheduler (AutoSys) CA Service Catalog CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

The igateway process starts up fine during the regular service restarts. However, the log (/opt/CA/SharedComponents/iTechnology/igateway.log) returns the following error every time during the startup.

# cd /opt/CA/SharedComponents/iTechnology
# ./S99igateway start
starting igateway
# tail -f igateway.log
[22534245230336] 09/19/22 17:07:18 ERROR :: JVMLoader::loadJVM : unable to load jvm [ jvmpath : libjvm.so ] Error Code [ 0 ]
[22510204503808] 09/19/22 17:07:39 ERROR :: JVMLoader::loadJVM : unable to load jvm [ jvmpath : libjvm.so ] Error Code [ 0 ] 

The EEM application appears to be stable. Portal allows the login and renders both authentication and authorisation fine.

Environment

CA Embedded Entitlements Manager: 12.6.2 and higher

OS: Linux

Cause

This message is due to the service unable to access the file libjvm.so

Resolution

Correcting the "javahome" in the "igateway.conf" file resolves this error.

Navigate to iTechnology directory (/opt/CA/SharedComponents/iTechnology)

Take a backup of file igateway.conf

Open for edit and find the section -

 <JVMSettings>
        <loadjvm>true</loadjvm>
        <javahome>/opt/CA/SharedComponents/EmbeddedEntitlementsManager/jre18</javahome>
        <Properties name="jvm_heapsize">

Correct the tag <javahome> pointing to the jre directory under EmbeddedEntitlementsManager.

 <JVMSettings>
        <loadjvm>true</loadjvm>
        <javahome>/opt/CA/SharedComponents/EmbeddedEntitlementsManager/jre</javahome>
        <Properties name="jvm_heapsize">

Save the file and restart the service. The log (igateway.log) is clear of error message.

Note: By default the igateway.log is configured to capture only the error messages. It is good if it does not log any messages during the process startup.

Additional Information

Another thing to check is ownership of the above jre path.     

 /opt/CA/SharedComponents/iTechnology folder ownership  should be same as the ownership of the jre path being referred to above.

 

Otherwise, the user starting igateway (normally it is the user who owns the folder iTechnology)  will not be able to read the files from the jre folder and could cause errors loading libjvmpath  or libepipoz